Guide d’utilisation

Comment utiliser Zenovix Storage Manager

Guide pratique pour analyser des dossiers, comprendre l’espace occupé et vérifier les doublons avec l’édition gratuite, puis enregistrer, exporter, archiver et récupérer avec Pro.

Le tableau de bord garde visibles l’analyse, les filtres et le contexte de vérification.

Le flux de travail en un coup d'œil

Cinq phases, dans l'ordre dans lequel vous les utilisez.

  1. 1 Balayage Sélectionnez le dossier, Fast Scan ou analyse complète
  2. 2 Analyser Onglets, filtres et informations du tableau de bord
  3. 3 Vérifier Doublons, fichiers similaires et dossiers vides
  4. 4 Effectuer Archiver, Corbeille ou Suppression permanente
  5. 5 Restaurer Le Pro Recovery Centre restaure les archives

Démarrage rapide

Premier passage recommandé

  1. Installez Zenovix Storage Manager à partir du Microsoft Store.
  2. Ajoutez un dossier, un lecteur ou un partage réseau ciblé dans la configuration de l'analyse.
  3. Utilisez Fast Scan pour un aperçu rapide du stockage ou désactivez-le pour une analyse d'analyse complète des doublons.
  4. Utilisez les paramètres si vous souhaitez modifier le niveau d'analyse, la conception, les règles de correspondance, le comportement des fichiers cloud ou le nombre de lignes.
  5. Laissez la correspondance exacte SHA-256 activée pour la première analyse complète.
  6. Utilisez le tableau de bord d'analyse interactif avant de signaler les fichiers en cours de révision.
  7. Utilisez Pro pour enregistrer les résultats de l'analyse si la vérification dure plus d'une session.
  8. Utilisez d'abord l'archive Pro si vous souhaitez un chemin de récupération Zenovix.

Flux de travail du produit

Travaillez dans des phases contrôlées, de l'analyse à la récupération.

Zenovix est conçu autour d’un nettoyage basé sur des preuves. Chaque étape vous donne plus de contexte avant que les actions vérifiées n'archivent, ne suppriment ou suppriment des fichiers.

01

Avant de numériser

Choisissez une étendue d'analyse claire

Commencez par les dossiers, lecteurs ou emplacements réseau qui subissent réellement une pression de stockage. La configuration de l'analyse maintient la portée sélectionnée visible avant l'analyse, et le sélecteur de dossier affiche d'abord les répertoires Windows et cloud courants lorsqu'ils sont disponibles.

  • Utilisez « Ajouter un dossier » pour sélectionner les dossiers que vous souhaitez que Zenovix Storage Manager analyse.
  • Dans la sélection des dossiers, choisissez un ou plusieurs points de départ intentionnels au lieu de marquer un lecteur entier par habitude.
  • Les partages réseau sont pris en charge. Dans le sélecteur de dossier, entrez un chemin tel que \\server\share si vous souhaitez analyser un emplacement réseau.
  • Pour OneDrive ou d'autres dossiers synchronisés, rendez les fichiers importants disponibles localement avant la analyse.
  • Évitez les dossiers système Windows, sauf si vous souhaitez les examiner consciemment.
  • Utilisez des dossiers de démarrage plus petits si une arborescence de dossiers est très volumineuse ou profondément imbriquée.
02

Simple ou avancé

Choisissez le niveau d'analyse adapté à la tâche

Utilisez les boutons De base et Avancé dans la barre de gauche ou Paramètres > Niveau d'analyse pour choisir l'expérience de analyse. Le mode simple est le chemin guidé par défaut. Le mode avancé affiche la barre de flux de travail détaillée, des options de correspondance plus approfondies et des vues d'analyse supplémentaires.

  • Le mode simple exécute la barre de gauche via Sélectionner un dossier, Afficher les résultats, Vérifier les doublons, Vérifier les fichiers, Vider les dossiers et Nettoyer.
  • Le mode simple maintient la configuration de analyse concentrée et utilise des valeurs par défaut conservatrices pour une correspondance exacte lors de la vérification des doublons.
  • Le mode simple conserve également Recovery Centre et les paramètres disponibles sous « Outils » dans la barre de gauche.
  • Le mode avancé affiche la configuration de la analyse, le tableau de bord d'analyse, les doublons exacts, la correspondance de similarité, la sélection de vérification, les dossiers vides, les archives, Recovery Centre et les paramètres.
  • Utilisez le mode avancé lorsque vous avez besoin d'une correspondance de métadonnées, d'une correspondance de similarité par nom ou contenu, d'options de type de contenu ou d'onglets de tableau de bord détaillés.
  • La correspondance de similarité apparaît comme une zone d'inspection en mode avancé, car les fichiers similaires avec une certitude moindre nécessitent une inspection plus lente.
  • Le Recovery Centre reste disponible en tant qu'outil en mode simple, mais le flux de travail de récupération lui-même nécessite Pro.
03

Installation de analyse

Sélectionnez Fast Scan ou une analyse d'analyse complète

La configuration de l'analyse affiche les sources sélectionnées, les actions d'analyse, l'état actuel, la progression et un résumé en un seul endroit. Utilisez Fast Scan pour un aperçu plus rapide ou ignorez-le lorsque vous avez besoin de résultats de vérification en double, de similarité et plus approfondis.

  • Fast Scan analyse particulièrement rapidement l'utilisation du stockage, les types de fichiers, les fichiers volumineux et les dossiers vides.
  • Lorsque Zenovix est lancé en tant qu'administrateur sur les volumes NTFS locaux pris en charge, Fast Scan peut utiliser l'analyse des métadonnées de la table de fichiers maître NTFS pour une présentation plus rapide.
  • Si l'analyse des métadonnées NTFS n'est pas disponible pour un emplacement, Zenovix revient à l'énumération des dossiers sécurisés.
  • Fast Scan peut analyser les dossiers locaux, les dossiers cloud disponibles localement et les partages réseau.
  • Utilisez une analyse analytique complète lorsque la tâche nécessite une correspondance de doublons, une correspondance de similarité ou des résultats d'inspection plus approfondis.
  • Une analyse d'analyse complète utilise les options de correspondance sélectionnées pour créer des candidats pour des doublons exacts, une vérification de similarité et un nettoyage.
  • Le commutateur de analyse rapide peut être modifié avant la analyse et est verrouillé pendant une analyse active.
  • Si Fast Scan est activé, les options de duplication ne sont pas disponibles car Fast Scan n'effectue pas ces correspondances.
  • « Démarrer l'analyse » lance le type d'analyse sélectionné avec les dossiers et les paramètres sélectionnés.
  • Suspendez l'analyse et reprenez l'analyse si vous souhaitez réduire temporairement l'activité du disque.
  • « Stop Scan » met fin prématurément à l'analyse active. Les versions plus récentes répondent plus rapidement lors des recherches de dossiers.
  • La barre de progression bouge visiblement pendant les analyses longues pour indiquer clairement que le travail du disque se poursuit.
  • Les fichiers ignorés sont signalés au lieu d'être masqués, afin que vous puissiez voir si des fichiers uniquement cloud, verrouillés ou inaccessibles manquaient.
  • Le résumé de l'analyse affiche les doublons amovibles, les dossiers vides, le stockage partageable et les détails des fichiers ignorés après une analyse.
  • Si les fichiers cloud uniquement ont été ignorés, téléchargez-les localement et effectuez une nouvelle analyse pour un résultat plus complet.
  • Si les informations du tableau de bord en double signalent qu'elles ne sont pas disponibles dans le Fast Scan, exécutez une analyse analytique complète sur ce dossier.
04

Paramètres

Définir les paramètres par défaut du workflow, du rapprochement et de l'audit

Les paramètres constituent l'emplacement central des préréglages qui étaient auparavant dispersés dans la configuration de la analyse et dans les menus. Ils incluent le niveau d'analyse, la conception, la correspondance des doublons, le comportement des fichiers cloud, les exclusions de sécurité, la limite d'âge des informations et les lignes du tableau.

  • Utilisez Réinitialiser les valeurs par défaut pour ramener les options de flux de travail, de rapprochement, de sécurité et de ligne au point de départ recommandé.
  • Le niveau d'analyse sélectionne Basique ou Avancé comme expérience d'analyse par défaut.
  • Le design peut suivre Windows ou définir Zenovix sur clair ou foncé.
  • « Match by SHA-256 hash » recherche les fichiers avec le même contenu.
  • « Exiger la même taille de fichier » conserve la correspondance exacte des doublons de manière conservatrice.
  • La correspondance par nom de fichier et date/heure peut affiner les candidats à vérifier, mais elle est moins claire que la correspondance par hachage.
  • La correspondance de similarité de noms trouve des fichiers portant des noms similaires lorsque les noms exacts ne suffisent pas.
  • La comparaison de similarité de contenu peut comparer des images, des vidéos ou des films, de l'audio ou de la musique, des documents ou des PDF et des archives.
  • Les paramètres en double sont modifiables pour une analyse complète avancée et ne sont pas disponibles lorsqu'ils ne sont pas en vigueur, comme pendant Fast Scan.
  • Forcer le téléchargement de fichiers cloud peut ouvrir des espaces réservés en ligne uniquement que le fournisseur de cloud peut télécharger lors de la analyse. Laissez cette option désactivée si vous ne souhaitez pas que l'analyse récupère les fichiers cloud sur l'appareil.
  • Les options de sécurité des fichiers système peuvent exclure les fichiers système, en lecture seule et cachés des résultats du nettoyage.
  • L’ancienne limite d’âge des fichiers contrôle les anciennes informations sur les fichiers et archive les alertes des candidats.
  • Les paramètres du tableau sélectionnent 50, 100, 250 ou 500 lignes pour la vérification des doublons, la vérification des fichiers, l'aperçu de récupération et les enregistrements d'archive.
05

analyse

Utiliser les onglets et les filtres du tableau de bord

Le tableau de bord analytique est interactif. Le mode simple le concentre sur l’impact sur le stockage et les prochaines étapes de vérification. Le mode avancé ajoute des onglets pour le stockage par type, l’activité des fichiers au fil du temps et les plus grands utilisateurs de stockage. Dans les deux modes, les visuels pris en charge peuvent restreindre la portée actuelle de l’analyse avant la vérification et l’exécution.

  • Les cartes d'informations récapitulatives affichent les candidats au nettoyage actuels, les fichiers candidats hérités, la plus grande catégorie de fichiers, le plus grand dossier en termes de portée et les dossiers vides lorsque ces informations sont disponibles.
  • Les cartes d'informations vierges sont masquées pour que le tableau de bord reste concentré sur les résultats réels de l'analyse.
  • Le mode simple met en évidence les doublons amovibles, la plus grande catégorie, le plus grand dossier, la croissance récente et les dossiers vides.
  • Le mode avancé ajoute des fichiers similaires, des candidats d'archive, un historique temporel, des pannes de candidats et techniques.
  • Le stockage par type inclut le stockage par catégorie et la répartition de la taille des fichiers.
  • L'activité des fichiers au fil du temps affiche l'activité de création ou de modification par année, trimestre, mois ou jour - avec Retour aux années et Monter d'un niveau après la plongée.
  • Les plus grands utilisateurs de stockage incluent des vues telles que les 10 principaux types de fichiers, les dossiers les plus volumineux et les fichiers les plus volumineux.
  • La catégorie sunburst est cliquable pour plonger dans un groupe de catégories, une catégorie ou un type de fichier ; l'exploration ramène à la vue d'ensemble.
  • Le volet de détails Fichiers ciblés affiche les fichiers ou dossiers derrière la sélection actuelle et peut être ouvert dans une fenêtre d'aperçu distincte.
  • Cliquer sur un visuel de tableau de bord pris en charge applique des filtres croisés sur les vues liées.
  • Les puces de filtre actif apparaissent en haut du tableau de bord afin que vous puissiez voir et supprimer le contexte du filtre.
  • Les cartes, graphiques, tableaux et listes de contrôle sont mis à jour vers la portée filtrée.
  • Exemple : la sélection de candidats au nettoyage en double, puis « Audio » limite le tableau de bord aux fichiers audio dans cette étendue de nettoyage.
  • Si vous passez ensuite en vérification, Zenovix conserve le même périmètre d'analyse permanent afin que vous puissiez continuer à travailler uniquement avec ces fichiers.
  • Cliquez à nouveau sur le même visuel, supprimez le filtre à l'aide de la barre de filtre, utilisez l'exploration ou « Réinitialiser le filtre » pour réinitialiser complètement le tableau de bord.
  • Vérifiez toujours les fichiers sélectionnés avant de les archiver, de les placer dans la corbeille ou de les supprimer définitivement.
06

Menus

Utiliser le fichier, la récupération, les paramètres et l'aide

Le menu supérieur se concentre sur les commandes de fichiers, de récupération et d'aide. Les préférences du flux de travail telles que le niveau d'analyse, la conception et les numéros de ligne se trouvent dans les paramètres plutôt que dans un menu d'affichage séparé ; Les actions en double à l'échelle du groupe se trouvent dans l'écran de vérification des doublons.

  • Utilisez Fichier pour ouvrir l'analyse, enregistrer, enregistrer sous, vérifier en profondeur l'analyse enregistrée, annuler la vérification approfondie et exporter les résultats visibles au format CSV.
  • Utilisez la récupération pour l'emplacement de restauration, restaurer l'archive, restaurer la destination, renommer l'archive, nettoyer l'archive et supprimer l'archive.
  • La destination de restauration vous permet de choisir un dossier de destination ou d'utiliser les chemins d'origine.
  • Le menu Mettre à niveau vers Pro apparaît lorsque les actions Pro sont verrouillées.
  • Utilisez les paramètres pour le niveau d'analyse, la conception, les règles de correspondance, le comportement des fichiers cloud, les exclusions de sécurité et le nombre de lignes.
  • Utilisez les actions de groupe dans la vérification des doublons exacts ou similaires si vous souhaitez modifier les groupes visibles avec une règle.
  • Les actions de groupe incluent Conserver le plus ancien, Conserver le plus récent, Conserver le plus grand, Conserver le plus petit, Conserver le chemin le plus court, Conserver le chemin le plus long, Conserver tout et Effacer la sélection.
  • Vérifiez les filtres actifs et la taille du groupe visible avant d'utiliser des actions de groupe - les commandes s'appliquent au jeu de contrôle visible.
  • Utilisez l'aide pour l'assistance, le manuel, les modifications, la FAQ et à propos de Zenovix Storage Manager.
07

Résultats enregistrés

Enregistrez des vérifications volumineuses avec Pro et continuez plus tard

Les grandes structures de dossiers nécessitent du temps pour une inspection approfondie. Zenovix Pro peut enregistrer les résultats de l'analyse afin que vous puissiez les charger plus tard et continuer la même analyse au lieu de recommencer depuis le début.

  • Utilisez Fichier > Enregistrer ou Enregistrer sous pour créer un fichier d'analyse .zenovix si une analyse volumineuse nécessite plus d'une session.
  • Utilisez Fichier > Ouvrir l'analyse ou ouvrez un fichier d'analyse Zenovix à partir de Windows pour revenir ultérieurement à Analyse et espace de vérification.
  • Une fois ouvert, Zenovix valide le fichier enregistré et restaure l'espace de travail de vérification avant d'afficher les résultats.
  • Si des fichiers ont été modifiés ou sont manquants depuis leur enregistrement, Zenovix peut réinitialiser les décisions d'inspection concernées afin que les décisions de nettoyage obsolètes ne soient pas réutilisées en silence.
  • Utilisez les résultats Pro enregistrés pour des audits approfondis et à long terme des photothèques, des dossiers de projet, des archives ou des disques externes.
  • Utilisez Fichier > Exporter les résultats visibles en tant que CSV si vous avez besoin d’un relevé fichier par fichier de la portée visible de la vérification.
  • Utilisez le rapport CSV pour vérifier quels fichiers sont conservés, marqués pour le nettoyage ou non révisés.
08

Vérification de la profondeur

Vérifier l'intégrité des analyses enregistrées grâce à la vérification du contenu

Lors de l'ouverture d'une analyse enregistrée, Zenovix vérifie d'abord les métadonnées du fichier (taille et heure de modification). Pour la validation complète du contenu, la vérification approfondie calcule les hachages SHA-256 et confirme que les fichiers sont inchangés.

  • La vérification des métadonnées est rapide et détecte les fichiers déplacés ou supprimés.
  • La vérification approfondie effectue des contrôles de contenu réel à l'aide du hachage SHA-256.
  • Pour de grandes quantités de données, la vérification approfondie ne s'exécute pas automatiquement afin que le chargement reste réactif.
  • Utilisez une vérification approfondie si vous voulez être sûr que le contenu du fichier correspond à l'analyse d'origine.
  • Une vérification approfondie s'exécute automatiquement avant les opérations d'archivage Pro afin que seuls les fichiers actuels soient traités.
  • Après une vérification approfondie, Zenovix indique le nombre de fichiers vérifiés, modifiés ou manquants.
09

Vérification

Enquêter sur les dossiers candidats en double et vides

Les décisions de nettoyage contrôlées par l'utilisateur sont prises lors de l'audit. Zenovix sépare les ensembles de doublons exacts des résultats avancés de correspondance de similarité afin que les correspondances plus incertaines ne se mélangent pas dans le chemin de suppression le plus fiable.

  • La vérification exacte des doublons est destinée aux groupes de haute sécurité.
  • La vérification de similarité est disponible en mode avancé pour les fichiers similaires nécessitant un contrôle plus détaillé.
  • L'écran de vérification des doublons comporte un atelier pour les groupes en double à gauche et une comparaison du groupe sélectionné avec les règles de conservation à droite.
  • Utilisez Précédent et Suivant pour les groupes en double page par page. Modifiez la taille de la page dans Paramètres > Vérifier les tableaux.
  • Le mode facile maintient les filtres de contrôle concentrés ; Le mode avancé ajoute des filtres pour la taille du groupe, la catégorie et le type de hit.
  • Les indicateurs Conserver, Nettoyer et Non révisé affichent la décision actuelle pour chaque élément avant qu'une action ne soit entreprise.
  • Des règles telles que le chemin le plus ancien, le plus récent, le plus grand, le plus petit, le plus court ou le plus long permettent de marquer les groupes de manière cohérente. Les règles basées sur la taille sont particulièrement utiles pour les vérifications de similarité.
  • Les actions de groupe peuvent appliquer ces règles de conservation aux groupes de duplication ou de similarité visibles.
  • Cliquez avec le bouton droit sur les groupes en double, les cartes d'aperçu ou les lignes de fichiers pour effectuer des actions rapides telles que Conserver la sélection, Marquer la sélection pour le nettoyage ou Marquer la sélection comme non révisée.
  • L'aperçu de groupe affiche des vignettes lorsqu'elles sont disponibles - avec une gestion améliorée des formats d'image tels que HEIC.
  • Review Cleanup Selection collecte les fichiers révisés en un seul endroit afin que vous puissiez rechercher, filtrer par état de révision, prévisualiser les fichiers et prendre des décisions finales de conservation ou de nettoyage avant l'exécution.
  • Les grandes listes dans les fichiers d'analyse utilisent Load More pour que les analyses très volumineuses restent réactives.
  • La vérification des dossiers vides vous permet de rechercher des chemins de dossiers, de filtrer par état de vérification et de marquer les dossiers vides comme Conserver ou Nettoyer séparément des doublons de fichiers.
10

Effectuer

Appliquer consciemment les actions testées

L'exécution est la phase d'action finale. Les utilisateurs gratuits peuvent déplacer les éléments cochés vers la corbeille ou les supprimer définitivement ; Zenovix Pro ajoute le chemin d'archive récupérable.

  • Archive est une option Pro qui copie les fichiers vérifiés vers un emplacement d'archive, vérifie la copie, supprime l'original et écrit un enregistrement de récupération sauvegardé par manifeste.
  • Les dossiers vides sélectionnés pour l'archive sont suivis avec des marqueurs de récupération afin que le dossier puisse être recréé ultérieurement.
  • La Corbeille utilise le comportement de restauration Windows, peut être limitée par la capacité de la Corbeille et n'est pas suivie dans le Zenovix Recovery Centre.
  • La suppression permanente est confirmée par l'utilisateur, ne crée pas d'enregistrement de récupération Zenovix et doit être considérée comme définitive.
  • Zenovix écrit un résumé d'exécution pour suivre les éléments terminés, ignorés et ayant échoué.
  • Lisez les réussites partielles, les fichiers ignorés et les erreurs avant de lancer une autre exécution de nettoyage.
11

Archive

Utilisez l'archive Pro si vous souhaitez un chemin de récupération Zenovix

L'archive Pro est l'option de nettoyage recommandée si vous souhaitez que Zenovix conserve des preuves vérifiables de ce qui s'est passé. L'écran d'archive garde l'objectif et l'exécution clairs ; les détails des archives étendues restent disponibles si nécessaire.

  • Sélectionnez Archiver dans la phase d'exécution Pro après avoir vérifié les décisions de dossiers en double ou vides.
  • Vérifiez l’emplacement de l’archive avant d’exécuter Archive Verified Cleanup.
  • Utilisez les détails étendus de l'archive si vous souhaitez donner un nom d'archive plus clair ou vérifier les détails du manifeste avant l'exécution.
  • Conservez le manifeste de récupération et les fichiers d'archive ensemble afin que le Recovery Centre puisse les afficher et les restaurer ultérieurement.
  • Après l'exécution, lisez les indicateurs de progression et de résultats afin de ne pas manquer les éléments ignorés ou échoués.
  • N'utilisez la Corbeille ou la Suppression matérielle que si vous comprenez leurs différentes limites de récupération.
12

Recovery Centre

Restaurer les fichiers archivés à la demande avec Pro

Le Recovery Centre Pro vous permet d'inspecter les enregistrements d'archives, de prévisualiser les chemins de restauration et de restaurer les éléments sélectionnés ou des tâches d'archivage entières.

  • Utilisez Récupération > Emplacement de récupération pour sélectionner l'emplacement d'archive que vous souhaitez que Zenovix examine.
  • Le Recovery Centre se met à jour lorsqu'il est ouvert ou lors du changement d'emplacement de restauration.
  • Le menu de récupération offre un accès rapide à l'emplacement de restauration, à la restauration de l'archive, à la destination de restauration, à renommer, nettoyer et supprimer les archives.
  • Définissez le nombre de lignes d’enregistrement d’aperçu et d’archive dans Paramètres > Tables d’audit.
  • Renommez les enregistrements d'archive si un ID de travail généré n'est pas suffisamment descriptif.
  • Prévisualisez les chemins de récupération afin de savoir où vont les fichiers, y compris les dossiers en conflit si un chemin d'origine est déjà occupé.
  • Restaurez les fichiers sélectionnés, l'intégralité de l'archive ou dans votre propre dossier de destination si vous ne souhaitez pas restaurer les chemins d'origine.
  • Filtrez et parcourez les lignes d'aperçu par catégorie, statut et chemin avant de choisir ce que vous souhaitez restaurer ou ignorer.
  • Double-cliquez sur un élément d'aperçu en double disponible ou cliquez sur sa vignette pour ouvrir la copie archivée avec l'application associée.
  • Purgez les enregistrements d'archive uniquement si vous souhaitez supprimer les entrées restaurées ou manquantes du manifeste ; Supprimez les archives uniquement si vous n'avez plus besoin de ce chemin de récupération.

CLI

Utilisez le Zenovix CLI pour les rapports Pro en lecture seule.

Le Zenovix CLI est une interface de ligne de commande sécurisée pour l'analyse du stockage, les rapports, les analyses planifiées, le Storage History Workbooks et les exportations. Il est disponible avec Zenovix Pro et complète l'application de bureau plutôt que de la remplacer.

CLI

aperçu

À quoi sert le Zenovix CLI

Utilisez la CLI pour une analyse de stockage Windows en ligne de commande répétable, des rapports PowerShell, une analyse planifiée, une analyse NAS, des analyses UNC, Storage History Workbooks ou des fichiers d'exportation pour Excel, Power BI et d'autres outils de reporting.

  • Disponible avec Zenovix Pro.
  • Exécute des commandes d’analyse et de création de rapports en lecture seule.
  • Fonctionne avec les dossiers, les lecteurs, les chemins UNC, les périphériques NAS et les lecteurs connectés.
  • Peut écrire des sorties JSON, CSV, XLSX, Storage History Workbook et base de données ODBC.
  • Accessible à partir de PowerShell, des scripts et du planificateur de tâches Windows.
  • Les utilisateurs gratuits peuvent Zenovix --help et Zenovix --version effectuer.
SAFE

Modèle de sécurité

La CLI n'exécute jamais de nettoyages

La CLI est intentionnellement protégé en écriture. L'automatisation de la ligne de commande est utile pour l'analyse et la création de rapports, mais le nettoyage reste dans l'application de bureau, où l'état de l'analyse, la sélection des archives, les aperçus de récupération et les enregistrements de récupération sont visibles.

  • Le Zenovix CLI ne supprime jamais les fichiers.
  • Le Zenovix CLI n’archive jamais de fichiers.
  • Le Zenovix CLI ne récupère jamais les fichiers.
  • Le Zenovix CLI ne renomme jamais les fichiers.
  • Le Zenovix CLI ne déplace jamais de fichiers.
  • Le Zenovix CLI ne nettoie pas les dossiers et n'effectue pas de nettoyage automatique.
  • Noms de commandes destructeurs comme supprimer, archive, restaurer, nettoyage, faire le ménage, retirer, se déplacer, rebaptiser, corbeille-vide, dédoublonner et réparer sont rejetées.
  • Utilisez l'application de bureau pour les workflows de nettoyage, d'archivage, de restauration et de centre de récupération basés sur l'audit.
01

installation

Utiliser l'alias d'exécution de l'application Microsoft Store

Installez ou mettez à jour Zenovix Storage Manager à partir de Microsoft Store. Le package du magasin contient l'alias d'exécution zenovix.exe, donc la commande comme zénovix peut être démarré à partir du terminal Windows, de PowerShell, de l'invite de commande ou du planificateur de tâches.

zenovix --help
zenovix --version
  • Trouve Windows zénovix Sinon, vérifiez Paramètres Windows > Applications > Paramètres avancés de l'application > Alias ​​d'exécution de l'application.
  • Si Pro ne peut pas être vérifié, les commandes fonctionnelles échoueront en toute sécurité avant la analyse, indiquant que Zenovix Pro n'a pas pu être vérifié.
  • Les états de licence gratuits et inconnus peuvent afficher l'aide et la version, mais les commandes fonctionnelles nécessitent Pro.
02

utiliser

Structure de la ligne de commande

Le format général de la commande est :

zenovix <command> [arguments] [options]
  • Options globales : --help, -h, --version, --quiet, --json et --log <file>.
  • Commandes Pro fonctionnelles : scan, compare, top, health, history, export et profile.
  • Les noms réservés tels que résumé, croissance, doublons et informations ne sont pas documentés en tant que commandes publiques tant qu'ils ne sont pas implémentés.
03

balayage

Exécutez des analyses de stockage à partir de la ligne de commande

zenovix scan <path> [<path> ...] [options]

scan effectue une analyse de stockage sur les dossiers, les lecteurs, les chemins UNC, les périphériques NAS ou les lecteurs connectés. Utilisez-le pour les rapports planifiés, l'historique des classeurs et les exportations.

  • Les options de rapports en fichiers incluent --history <file.xlsx>, --output <folder>, --json, --csv et --xlsx.
  • La sortie ODBC utilise --output odbc --connection <DSN-ou-chaîne-de-connexion>. Ajoutez --report-output <folder> lorsque les fichiers JSON, CSV ou XLSX combinés nécessitent une destination.
  • Les autres options d'analyse comprennent --fast, --analysis, --top-folders <n>, --include <pattern>, --exclude <pattern>, --recursive true|false, --quiet et --log <file>.
zenovix scan D:\Photos
zenovix scan "\\server\Finance" --analysis --history "Storage History.xlsx"
zenovix scan D:\Data --json
zenovix scan D:\Data --xlsx --output "C:\Reports" --top-folders 25
zenovix scan D:\Data --output odbc --connection "ZenovixHistory"
zenovix scan D:\Data --output odbc --connection "ZenovixHistory" --xlsx --report-output "C:\Reports"
04

Rapports

Comparez, triez et exportez les données analysées

zenovix compare --history <file.xlsx> [options]
zenovix top folders|files|extensions <path> [options]
zenovix top folders|extensions --history <file.xlsx> [options]
zenovix export --history <file.xlsx> [--json] [--csv] [--xlsx] [--output <folder>]
  • compare compare le dernier scan avec le précédent dans un Storage History Workbook.
  • top affiche les dossiers, fichiers ou extensions les plus volumineux d'un chemin ou d'un classeur.
  • export exporte le dernier scan d'un Storage History Workbook.
  • Profitez --count<n>, --json, --quiet et --log <file>, là où il est pris en charge.
05

Cahier d'exercices d'histoire

Conservez l'historique de stockage sans supprimer les anciennes données

zenovix history info     [--history <file.xlsx>] [--json]
zenovix history validate [--history <file.xlsx>] [--json]
zenovix history init     [--history <file.xlsx>]
zenovix history repair   [--history <file.xlsx>]
  • Storage History Workbooks sont des fichiers XLSX pour une analyse répétée du stockage au fil du temps.
  • Le classeur peut être ouvert dans des outils compatibles Excel et analysé dans Power BI.
  • Le Zenovix CLI peut créer et joindre des données de classeur sans que Microsoft Excel soit installé.
  • réparation de l'histoire conserve la structure du classeur sans supprimer ni réécrire les données d'analyse historiques.
PROFILE

Profils enregistrés

Exécuter un plan d'analyse du bureau par son ID stable

zenovix profile run <profile-id> [--quiet] [--log <file>]
  • profile run exécute un profil créé dans la fenêtre Plans d'analyse planifiés de l'application de bureau.
  • Le profil enregistré fournit les chemins, filtres, le Storage History Workbook, les rapports JSON/CSV/XLSX et une destination ODBC facultative.
  • Le Planificateur de tâches Windows n'a besoin que de l'ID stable ; les paramètres du profil et les informations de connexion ODBC ne figurent pas sur la ligne de commande de la tâche planifiée.
  • Les options d'analyse et de sortie ne peuvent pas être remplacées avec profile run ; modifiez plutôt le plan enregistré dans l'application de bureau.
zenovix profile run 63fc6e99-42f7-47a7-9972-83ec998aab31 --quiet
06

Santé

Vérifier l'état de préparation de l'analyse avant les tâches planifiées

zenovix health <path> [options]
  • health vérifie si un chemin peut être analysé.
  • Il signale les accès, les fichiers ignorés, les longs chemins, la vitesse d'analyse et une estimation du débit de lecture.
  • Les options incluent --json, --quiet et --log <file>.
07

automation

Exemples de PowerShell et de planification des tâches

Utilisez PowerShell pour créer des rapports ad hoc et planifier des tâches pour les tâches d'analyse répétables.

zenovix scan D:\Data --json | Out-File "C:\Reports\latest-storage.json" -Encoding utf8
zenovix top folders --history "C:\Reports\Storage History.xlsx" --count 20 --json
Program/script: zenovix
Arguments: scan "D:\Data" --history "C:\Reports\Storage History.xlsx" --xlsx --output "C:\Reports" --quiet --log "C:\Reports\zenovix.log"
  • Placez les chemins d’accès avec des espaces pour les dossiers, les partages réseau et les classeurs entre guillemets.
  • Profitez --quiet pour les tâches planifiées pour lesquelles vous n'avez besoin que de fichiers et de journaux.
  • Profitez --log <file> pour joindre les journaux d'exécution pour un dépannage ultérieur.
08

dépense

Sortie JSON, CSV, XLSX, workbook et ODBC

  • Profitez --json lorsque les scripts ou la surveillance nécessitent une sortie structurée vers la sortie standard.
  • Profitez --csv pour les exportations tabulaires légères.
  • Profitez --xlsx pour les rapports compatibles Excel et les flux de travail d'historique de stockage.
  • Profitez --output <folder> pour choisir le dossier de destination des exportations.
  • Profitez --history <file.xlsx> si vous souhaitez joindre une analyse ou lire un classeur.
  • Utilisez --output odbc --connection <value> pour ajouter un instantané d'analyse immuable à une base de données ODBC. La valeur peut être un nom DSN ou une chaîne de connexion ODBC complète.
  • Utilisez --report-output <folder> pour les fichiers de rapports JSON, CSV ou XLSX lorsque --output odbc occupe l'option de sortie.
  • ODBC peut être combiné avec --history, --json, --csv et --xlsx ; toutes les destinations utilisent le même instantané d'analyse terminé.
09

Codes de sortie

Des résultats adaptés à l'automatisation

  • 0- Succès.
  • 1– Arguments invalides ou commande destructrice rejetée.
  • 2– L'analyse ou la commande a échoué.
  • 3– Accès refusé.
  • 4– Erreur de classeur.
  • 5– Erreur interne.
  • 6– Zenovix Pro requis ou le statut Pro ne peut pas être vérifié.
  • 7– Échec de la connexion ODBC, du schéma ou de l'écriture en base de données ; la transaction a été annulée.
  • 8– Échec de l'exportation du rapport JSON, CSV ou XLSX après la fin de l'analyse.
PRO

Plans d'analyse planifiés

Des plans réutilisables, exécutés manuellement ou planifiés

Un plan d'analyse planifié enregistre ensemble les sources d'analyse, les paramètres et les destinations de rapports, pour ne jamais les configurer deux fois. Les plans sont une fonctionnalité Pro ; Zenovix crée et gère la planification via le Planificateur de tâches de Windows.

  • Créez, modifiez, dupliquez et supprimez des plans réutilisables.
  • Exécutez un plan à la demande ou automatiquement selon une planification.
  • Activez, désactivez et gérez chaque planification directement depuis Zenovix.
  • Les profils d'analyse enregistrés peuvent aussi être exécutés depuis la CLI à l'aide d'un identifiant de profil stable.
DB

Historique de stockage ODBC

Exportez un historique immuable vers une base de données

L'exportation de l'historique de stockage via ODBC envoie des instantanés d'analyse immuables vers une base de données compatible ODBC pour l'historique à long terme, les rapports historiques et l'analyse des tendances dans des outils tels que Power BI. Elle peut être combinée avec les Storage History Workbooks et les rapports JSON, CSV ou XLSX.

  • L'interface accepte un DSN, une chaîne de connexion complète ou un fichier de base de données avec un pilote ODBC 64 bits installé.
  • Zenovix détecte les pilotes et DSN installés ; il n'inclut ni n'installe silencieusement de pilotes de base de données.
  • Utilise des écritures transactionnelles et évite de dupliquer l'historique en cas de nouvelle tentative.
  • La zone Storage History des paramètres et l'onglet ODBC des Plans d'analyse planifiés permettent d'enregistrer la destination, de tester la connexion, de valider le schéma et de le préparer.
  • Les destinations Microsoft Access bénéficient de contrôles de capacité ; aucune limite universelle de taille de fichier n'est attribuée aux autres fournisseurs.
  • Lorsque l'application de bureau enregistre une destination ODBC, les valeurs sensibles comme les mots de passe sont protégées par le Gestionnaire d'identification Windows. Une valeur CLI directe pour --connection est fournie pour cette invocation.
FAQ

Plus d'aide

Sujets de FAQ correspondants

Le FAQ CLI répond aux questions courantes sur l'accès gratuit et professionnel, PowerShell, la planification des tâches, les appareils NAS, les chemins UNC, Excel, Power BI et pourquoi le nettoyage reste un flux de travail de bureau.

Vues dans le manuel

Les principaux domaines de Zenovix Storage Manager.

Choisissez ce qu'il faut analyser
Votre stockage en un coup d'œil
Vérifiez les doublons exacts en toute confiance
Confirmez chaque fichier avant le nettoyage
Rangez les dossiers vides
Nettoyez en toute sécurité, récupération intégrée
Votre langue, votre thème, vos règles

Dépannage

Situations courantes d'analyse, de nettoyage et de restauration.

L'analyse semble lente

Les dossiers volumineux, les partages réseau, les dossiers cloud et la correspondance de similarité de contenu prennent plus de temps, car Zenovix donne la priorité à une identification fiable plutôt qu'aux abréviations dangereuses. Réduisez la portée de l'analyse, utilisez Fast Scan pour un aperçu rapide ou lancez Zenovix sur les lecteurs NTFS pris en charge en tant qu'administrateur.

Après Fast Scan, il manque des résultats en double

Fast Scan est destiné à l'aperçu du stockage, aux types de fichiers, aux fichiers volumineux et aux dossiers vides. Exécutez une analyse d'analyse complète lorsque vous avez besoin de doublons exacts, de correspondances de similarité ou de candidats au nettoyage.

Les fichiers cloud ont été ignorés

Les fichiers cloud uniquement peuvent ne pas être disponibles localement. Téléchargez les fichiers, marquez-les comme disponibles sur cet appareil ou activez Forcer le téléchargement des fichiers cloud dans les paramètres.

Les paramètres de correspondance sont désactivés

Les paramètres en double ne sont pas utilisés par Fast Scan et les options de correspondance complètes font partie de l'analyse avancée. Accédez à Avancé et exécutez une analyse analytique complète.

Fichiers modifiés après la analyse

Si des fichiers sont déplacés, modifiés ou supprimés après la analyse, l’espace de vérification peut ne plus s'adapter au support de données. Les analyses enregistrées valident les fichiers une fois ouverts, mais une nouvelle analyse est plus sûre avant de nettoyer les dossiers modifiés.

Vous souhaitez continuer une vérification plus tard

Avec Pro, enregistrez les résultats de l'analyse avant de quitter une vérification important. Chargez-les plus tard, générez un rapport CSV sur l'état de vérification de chaque fichier si nécessaire, ou utilisez le Zenovix CLI pour des tâches de reporting pures.

Une commande CLI signale que Pro est requis

Les commandes fonctionnelles CLI nécessitent un Zenovix Pro actif. Si le statut Pro ne peut pas être vérifié, la CLI échouera sûrement avant la analyse. Ouvrez Zenovix Storage Manager, vérifiez l'accès au compte du magasin Microsoft et transmettez au support le message exact de la CLI.

zenovix ne trouve pas le planificateur de tâches

Vérifiez si l'alias d'exécution Zenovix est activé dans les paramètres Windows. Utilisez zenovix comme programme dans la planification des tâches et placez les chemins d'analyse, les chemins du classeur, les dossiers de sortie, --quiet et --log dans le champ d'argument.

La poubelle ne suffit pas

Réduisez la sélection, libérez de l'espace dans la corbeille ou choisissez une autre option d'exécution vérifiée. N'utilisez la suppression définitive que si vous acceptez qu'il n'y a aucune garantie de récupération.

Un fichier ne peut pas être ouvert ou restauré

Vérifiez si le fichier est toujours disponible, si le chemin de destination existe et si une autre application utilise le fichier. Veuillez fournir une assistance avec le message exact.

L'assistance a besoin de détails sur la version

Ouvrez Aide > À propos de Zenovix Storage Manager et utilisez « Copier les informations d'assistance ». Incluez le texte ainsi que la phase utilisée et le message exact - surtout si vous avez des questions sur Microsoft Store ou Pro.

Avez-vous encore besoin d'aide ?

Soumettez les détails expliquant le problème.

Incluez votre version de Windows, la phase utilisée, le texte d'erreur exact et si le problème s'est produit lors de l'analyse, de la vérification, de l'archivage ou de la restauration.